Difference between revisions of "Requirements"

From Fail2ban
Jump to: navigation, search
(0.9 needs 2.6 https://github.com/fail2ban/fail2ban/pull/538)
(Required: fix expressions round 0.8.2 - wrong way round)
Line 6: Line 6:
 
** [http://www.python.org Python] >=2.6
 
** [http://www.python.org Python] >=2.6
  
* 0.8 branch (<0.8.2)
+
* 0.8 branch (>=0.8.2)
 
** [http://www.python.org Python] >=2.4
 
** [http://www.python.org Python] >=2.4
  
* 0.8 branch (>=0.8.2)
+
* 0.8 branch (<0.8.2)
 
** [http://www.python.org Python] >=2.3
 
** [http://www.python.org Python] >=2.3
  

Revision as of 23:23, 21 January 2014

Required

The only required dependency needed to run Fail2ban is Python. You need:

  • 0.8 branch (>=0.8.2)
  • 0.8 branch (<0.8.2)

Since 0.8.2, we set the minimal requirement back to Python 2.3. Lots of rock-solid server distributions are still shipped with this version of Python.

Optional

You may need some of these packages depending on your requirements: