Difference between revisions of "Talk:Manual"

From Fail2ban
Jump to: navigation, search
(Centos 3.7 does not include python 2.4)
 
Line 1: Line 1:
 
I am running Centos 3.7 which includes Python 2.2.3.  I tried to run fail2ban but it failed trying to export logging.  I have searched for info on upgrading to Python 2.4 but have '''not''' found a method for doing so without a lot of work, because of the system dependencies on Python.  Is it possible to port fail2ban to run on Python 2.2.3 ?  And can someone do that ?  If not, does someone know of an application similar to fail2ban that will run on Centos 3.7 ?
 
I am running Centos 3.7 which includes Python 2.2.3.  I tried to run fail2ban but it failed trying to export logging.  I have searched for info on upgrading to Python 2.4 but have '''not''' found a method for doing so without a lot of work, because of the system dependencies on Python.  Is it possible to port fail2ban to run on Python 2.2.3 ?  And can someone do that ?  If not, does someone know of an application similar to fail2ban that will run on Centos 3.7 ?
 +
 +
----
 +
 +
Fail2ban < 0.7.0 should work with Python 2.3 too. Maybe you can upgrade to this version of Python. Denyhosts does almost the same job as Fail2ban. [http://denyhosts.sourceforge.net/requirements.html But it requires Python 2.4].
 +
--[[User:Lostcontrol|Lostcontrol]] 07:03, 27 August 2006 (PDT)

Revision as of 15:03, 27 August 2006

I am running Centos 3.7 which includes Python 2.2.3. I tried to run fail2ban but it failed trying to export logging. I have searched for info on upgrading to Python 2.4 but have not found a method for doing so without a lot of work, because of the system dependencies on Python. Is it possible to port fail2ban to run on Python 2.2.3 ? And can someone do that ? If not, does someone know of an application similar to fail2ban that will run on Centos 3.7 ?


Fail2ban < 0.7.0 should work with Python 2.3 too. Maybe you can upgrade to this version of Python. Denyhosts does almost the same job as Fail2ban. But it requires Python 2.4. --Lostcontrol 07:03, 27 August 2006 (PDT)