Difference between revisions of "Requirements"

From Fail2ban
Jump to: navigation, search
(Required: fix expressions round 0.8.2 - wrong way round)
(Required: 0.9 requirements expanded)
 
Line 4: Line 4:
  
 
* 0.9 branch
 
* 0.9 branch
** [http://www.python.org Python] >=2.6
+
** [http://www.python.org Python] >=2.6, [http://www.python.org Python] >=3.2, [http://pypy.org PyPy]
  
 
* 0.8 branch (>=0.8.2)
 
* 0.8 branch (>=0.8.2)

Latest revision as of 03:02, 15 March 2014

Required

The only required dependency needed to run Fail2ban is Python. You need:

  • 0.8 branch (>=0.8.2)
  • 0.8 branch (<0.8.2)

Since 0.8.2, we set the minimal requirement back to Python 2.3. Lots of rock-solid server distributions are still shipped with this version of Python.

Optional

You may need some of these packages depending on your requirements: