Difference between revisions of "Requirements"

From Fail2ban
Jump to: navigation, search
(Optional: ipset)
(0.9 needs 2.6 https://github.com/fail2ban/fail2ban/pull/538)
Line 4: Line 4:
  
 
* 0.9 branch
 
* 0.9 branch
** [http://www.python.org Python] >=2.4
+
** [http://www.python.org Python] >=2.6
  
 
* 0.8 branch (<0.8.2)
 
* 0.8 branch (<0.8.2)

Revision as of 08:54, 3 January 2014

Required

The only required dependency needed to run Fail2ban is Python. You need:

  • 0.8 branch (<0.8.2)
  • 0.8 branch (>=0.8.2)

Since 0.8.2, we set the minimal requirement back to Python 2.3. Lots of rock-solid server distributions are still shipped with this version of Python.

Optional

You may need some of these packages depending on your requirements: