Difference between revisions of "Requirements"

From Fail2ban
Jump to: navigation, search
(0.9 will be at least 2.4 if not higher)
(Optional: ipset)
Line 25: Line 25:
 
* [ftp://ftp.porcupine.org/pub/security/index.html TCP Wrapper]
 
* [ftp://ftp.porcupine.org/pub/security/index.html TCP Wrapper]
 
* a mailer script
 
* a mailer script
 +
* ipset
  
 
[[Category:Fail2ban]]
 
[[Category:Fail2ban]]

Revision as of 23:43, 12 November 2013

Required

The only required dependency needed to run Fail2ban is Python. You need:

  • 0.8 branch (<0.8.2)
  • 0.8 branch (>=0.8.2)

Since 0.8.2, we set the minimal requirement back to Python 2.3. Lots of rock-solid server distributions are still shipped with this version of Python.

Optional

You may need some of these packages depending on your requirements: