Difference between revisions of "Requirements"

From Fail2ban
Jump to: navigation, search
(Undo revision 4328 by TaylorStone (talk) reason: link spam)
(revert)
Line 1: Line 1:
 +
== Required ==
 +
 +
The only required dependency needed to run {{Fail2ban}} is [http://www.python.org Python]. You need:
 +
 +
* 0.9 branch
 +
** [http://www.python.org Python] >=2.3
 +
 +
* 0.8 branch (<0.8.2)
 +
** [http://www.python.org Python] >=2.4
 +
 +
* 0.8 branch (>=0.8.2)
 +
** [http://www.python.org Python] >=2.3
 +
 +
* 0.6 branch
 +
** [http://www.python.org Python] >=2.3
 +
 +
Since 0.8.2, we set the minimal requirement back to [http://www.python.org Python] 2.3. Lots of rock-solid server distributions are still shipped with this version of [http://www.python.org Python].
 +
 
== Optional ==
 
== Optional ==
  
Line 7: Line 25:
 
* [ftp://ftp.porcupine.org/pub/security/index.html TCP Wrapper]
 
* [ftp://ftp.porcupine.org/pub/security/index.html TCP Wrapper]
 
* a mailer script
 
* a mailer script
 +
 +
[[Category:Fail2ban]]

Revision as of 23:23, 3 December 2011

Required

The only required dependency needed to run Fail2ban is Python. You need:

  • 0.8 branch (<0.8.2)
  • 0.8 branch (>=0.8.2)

Since 0.8.2, we set the minimal requirement back to Python 2.3. Lots of rock-solid server distributions are still shipped with this version of Python.

Optional

You may need some of these packages depending on your requirements: