Difference between revisions of "Requirements"

From Fail2ban
Jump to: navigation, search
(Required)
(0.8.2)
Line 6: Line 6:
 
** [http://www.python.org Python] >=2.3
 
** [http://www.python.org Python] >=2.3
  
* 0.8 branch
+
* 0.8 branch (<0.8.2)
 
** [http://www.python.org Python] >=2.4
 
** [http://www.python.org Python] >=2.4
 +
 +
* 0.8 branch (>=0.8.2)
 +
** [http://www.python.org Python] >=2.3
  
 
* 0.6 branch
 
* 0.6 branch
 
** [http://www.python.org Python] >=2.3
 
** [http://www.python.org Python] >=2.3
  
Since 0.9, we set the minimal requirement back to [http://www.python.org Python] 2.3. Lots of rock-solid server distributions are still shipped with this version of [http://www.python.org Python].
+
Since 0.8.2, we set the minimal requirement back to [http://www.python.org Python] 2.3. Lots of rock-solid server distributions are still shipped with this version of [http://www.python.org Python].
  
 
== Optional ==
 
== Optional ==

Revision as of 01:56, 6 March 2008

Required

The only required dependency needed to run Fail2ban is Python. You need:

  • 0.8 branch (<0.8.2)
  • 0.8 branch (>=0.8.2)

Since 0.8.2, we set the minimal requirement back to Python 2.3. Lots of rock-solid server distributions are still shipped with this version of Python.

Optional

However, you will need some of these softwares depending on your needs and setup: