Difference between revisions of "Requirements"

From Fail2ban
Jump to: navigation, search
m (Updated)
(Required)
Line 2: Line 2:
  
 
The only required dependency needed to run {{Fail2ban}} is [http://www.python.org Python]. You need:
 
The only required dependency needed to run {{Fail2ban}} is [http://www.python.org Python]. You need:
 +
 +
* 0.9 branch
 +
** [http://www.python.org Python] >=2.3
  
 
* 0.8 branch
 
* 0.8 branch
Line 9: Line 12:
 
** [http://www.python.org Python] >=2.3
 
** [http://www.python.org Python] >=2.3
  
For both branches, [http://www.python.org Python] 2.4 is recommended. It is developed using this version.
+
Since 0.9, we set the minimal requirement back to [http://www.python.org Python] 2.3. Lots of rock-solid server distributions are still shipped with this version of [http://www.python.org Python].
  
 
== Optional ==
 
== Optional ==

Revision as of 22:37, 21 May 2007

Required

The only required dependency needed to run Fail2ban is Python. You need:

Since 0.9, we set the minimal requirement back to Python 2.3. Lots of rock-solid server distributions are still shipped with this version of Python.

Optional

However, you will need some of these softwares depending on your needs and setup: