Difference between revisions of "Requirements"

From Fail2ban
Jump to: navigation, search
(Updated requirements)
Line 1: Line 1:
In order to run {{Fail2ban}}, you need:
+
== Required ==
  
* [http://www.python.org Python] >=2.3
+
The only required dependency needed to run {{Fail2ban}} is [http://www.python.org Python]. You need:
* [http://sourceforge.net/projects/log4py Log4py] (not needed with >=fail2ban-0.5.2)
+
  
You may also need:
+
* 0.7 branch
 +
** [http://www.python.org Python] >=2.4
 +
 
 +
* 0.6 branch
 +
** [http://www.python.org Python] >=2.3
 +
 
 +
For both branches, [http://www.python.org Python] 2.4 is recommended. It is developed using this version.
 +
 
 +
== Optional ==
 +
 
 +
However, you will need some of these softwares depending on your needs and setup:
  
 
* [http://www.netfilter.org/ Netfilter/Iptables]
 
* [http://www.netfilter.org/ Netfilter/Iptables]
 
* [http://www.shorewall.net/ Shorewall]
 
* [http://www.shorewall.net/ Shorewall]
 
* [ftp://ftp.porcupine.org/pub/security/index.html TCP Wrapper]
 
* [ftp://ftp.porcupine.org/pub/security/index.html TCP Wrapper]
 +
* a mailer script
  
 
[[Category:Fail2ban]]
 
[[Category:Fail2ban]]

Revision as of 10:53, 19 December 2006

Required

The only required dependency needed to run Fail2ban is Python. You need:

For both branches, Python 2.4 is recommended. It is developed using this version.

Optional

However, you will need some of these softwares depending on your needs and setup: