FAQ spanish

From Fail2ban
Revision as of 08:37, 11 May 2006 by ManuelArostegui (Talk | contribs) ('''Instalación''')

Jump to: navigation, search

General

¿Qué es Fail2ban?

Fail2ban lee los logs (por ejemplo) /var/log/pwdfail o /var/log/apache/error_log y banea todas aquellas ips que fallan un determinado número de veces. Este baneo se realiza actualizando el firewall (tipicamente iptables).

¿Qué licencia tiene Fail2ban?

Fail2ban es software libre y se distribuye bajo Licencia GNU. Usted puede copiar/modificar Fail2ban bajo los términos que se especifican en la Licencia GNU que está publicada en la Free Software Foundation.

¿Qué requirimientos necesita Fail2ban?

Están listados en la sección Requirements

Instalación

¿Hay paquetes precompilados como RPM/DEB?

Sí, puedes obtenerlos en la sección Downloads

¿Cómo se instalan los paquetes RPM/DEB?

Para instalar el paquete .rpm lo haremos con:

rpm -ivh fail2ban-X.X.X.rpm Si queremos instalar el paquete que contiene el source de fail2ban, (src.rpm) deberemos usar el siguiente mandato:

rpm --rebuild fail2ban-X.X.X.src.rpm

Tras esto el binario se instalará tipicamente en: /usr/src/RPM/RPMS/ix86

Una vez nos trasladamos a dicho directorio, sólo debemos usar la orden:

rpm -ihv fail2ban-X.X.X.rpm


Para instalar el paquete .deb sólo debemos usar:

dpkg -i fail2ban-X.X.X.deb

¿Se puede instalar Fail2ban usando repositorios tales como apt/yum/yast/urpmi/emerge?

Siempre y cuando los paquetes estén en los mirrors, puedes hacerlo, siguiendo los mandatos habituales de cada distribución:

Para Debian o distribuciones que usen Apt como gestor de paquetería.

apt-get install fail2ban

Distribuciones Fedora Core, usan Yum como gestor de paquetería.

yum install fail2ban

Suse utiliza Yast para gestionar la paquetería.

yast --install fail2ban

Si utilizamos Gentoo debemos usar Emerge.

emerge -va fail2ban -> Si se trata de un ebuild.

emerge -k fail2ban -> Si se trata de un binario.

Distribución Mandriva, utiliza Urpmi como gestor de paquetería.

urpmi fail2ban


Recuerda que debes verificar que tienes Fail2ban en tus repositorios