Talk:Requirements

From Fail2ban
Jump to: navigation, search

I like fail2ban and want to install on my server running on RHEL-3. But fail2ban need python-2.4, In RHEL-3, I am running python-2.2.3-6.5. can any one give me suggestion to implement fail2ban using python-2.2.3-6.5.


[S K Goel]

The Python version requirement on this page is not correct - I just tried to install fail2ban 0.6.2 on my SLES9 machine which contains Python 2.3 - this fails (no module distutils.core). The README for fail2ban 0.6.2 states that Python 2.4 is required, whereas this page states that 2.3 should be sufficient.

[Erik D]


You probably need to install the python-devel package on your system. Have a look here. --Lostcontrol 17:27, 28 April 2007 (CEST)

Python 2.4 requirement excluding a lot of serious users

Isn't there any way to have fail2ban run on Python 2.3 ?

RedHat 4 / CentOS 4 have Python 2.3 and these systems are rock solid and supported from their Vendor for many years to come. Having to update Python or install new version on the side seems to be quite a hassle.

Quite a lot of interesting projects seem to be so eager to keep up with the latest and greatest development tools and therefore are almost only available for the absolutely latest workstations, not the good stable servers all over the place. :-)


You are probably right ;) I won't change 0.8 to have it run on Python 2.3. Sorry... But I might consider Python 2.3 as the minimal requirement for the next development release (0.9). It is not the first time this "issue" is reported. --Lostcontrol 12:25, 8 May 2007 (CEST)